Commit fa24333c authored by Jonne Haß's avatar Jonne Haß Committed by Dennis Schubert

bump rubocop

parent 5a6f6c68
...@@ -36,10 +36,8 @@ Style/AlignHash: ...@@ -36,10 +36,8 @@ Style/AlignHash:
EnforcedColonStyle: table EnforcedColonStyle: table
# Mixing the styles looks just silly. # Mixing the styles looks just silly.
# REVIEW: Enable once https://github.com/bbatsov/rubocop/commit/760ce1ed2cf10beda5e163f934c03a6fb6daa38e Style/HashSyntax:
# is released. EnforcedStyle: ruby19_no_mixed_keys
#Style/HashSyntax:
# EnforcedStyle: ruby19_no_mixed_keys
# has_key? and has_value? are far more readable than key? and value? # has_key? and has_value? are far more readable than key? and value?
Style/DeprecatedHashMethods: Style/DeprecatedHashMethods:
...@@ -93,7 +91,7 @@ Style/SpaceInsideHashLiteralBraces: ...@@ -93,7 +91,7 @@ Style/SpaceInsideHashLiteralBraces:
# { ... } for multi-line blocks is okay, follow Weirichs rule instead: # { ... } for multi-line blocks is okay, follow Weirichs rule instead:
# https://web.archive.org/web/20140221124509/http://onestepback.org/index.cgi/Tech/Ruby/BraceVsDoEnd.rdoc # https://web.archive.org/web/20140221124509/http://onestepback.org/index.cgi/Tech/Ruby/BraceVsDoEnd.rdoc
Style/Blocks: Style/BlockDelimiters:
Enabled: false Enabled: false
# do / end blocks should be used for side effects, # do / end blocks should be used for side effects,
......
...@@ -227,7 +227,7 @@ group :development do ...@@ -227,7 +227,7 @@ group :development do
# Linters # Linters
gem "jshintrb", "0.3.0" gem "jshintrb", "0.3.0"
gem "rubocop", "0.29.1" gem "rubocop", "0.31.0"
# Preloading environment # Preloading environment
......
...@@ -447,10 +447,10 @@ GEM ...@@ -447,10 +447,10 @@ GEM
faraday (~> 0.9.0) faraday (~> 0.9.0)
nokogiri (~> 1.6) nokogiri (~> 1.6)
orm_adapter (0.5.0) orm_adapter (0.5.0)
parser (2.2.0.3) parser (2.2.2.2)
ast (>= 1.1, < 3.0) ast (>= 1.1, < 3.0)
phantomjs (1.9.8.0) phantomjs (1.9.8.0)
powerpack (0.1.0) powerpack (0.1.1)
pry (0.10.1) pry (0.10.1)
coderay (~> 1.1.0) coderay (~> 1.1.0)
method_source (~> 0.8.1) method_source (~> 0.8.1)
...@@ -601,9 +601,9 @@ GEM ...@@ -601,9 +601,9 @@ GEM
rspec-mocks (~> 3.2.0) rspec-mocks (~> 3.2.0)
rspec-support (~> 3.2.0) rspec-support (~> 3.2.0)
rspec-support (3.2.2) rspec-support (3.2.2)
rubocop (0.29.1) rubocop (0.31.0)
astrolabe (~> 1.3) astrolabe (~> 1.3)
parser (>= 2.2.0.1, < 3.0) parser (>= 2.2.2.1, < 3.0)
powerpack (~> 0.1) powerpack (~> 0.1)
rainbow (>= 1.99.1, < 3.0) rainbow (>= 1.99.1, < 3.0)
ruby-progressbar (~> 1.4) ruby-progressbar (~> 1.4)
...@@ -808,7 +808,7 @@ DEPENDENCIES ...@@ -808,7 +808,7 @@ DEPENDENCIES
roxml (= 3.1.6) roxml (= 3.1.6)
rspec-instafail (= 0.2.6) rspec-instafail (= 0.2.6)
rspec-rails (= 3.2.1) rspec-rails (= 3.2.1)
rubocop (= 0.29.1) rubocop (= 0.31.0)
ruby-oembed (= 0.8.14) ruby-oembed (= 0.8.14)
sass-rails (= 5.0.1) sass-rails (= 5.0.1)
selenium-webdriver (= 2.45.0) selenium-webdriver (= 2.45.0)
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment