Commit a7b854e7 authored by Jonne Haß's avatar Jonne Haß

add haml-lint

parent eddfa7cb
linters:
LineLength:
max: 120
SpaceInsideHashAttributes:
style: no_space
......@@ -236,9 +236,11 @@ group :development do
# Linters
gem "jshintrb", "0.3.0"
gem "rubocop", "0.32.1"
gem "haml_lint", "0.13.0"
gem "pronto", "0.4.2"
gem "pronto-jshint", "0.4.2"
gem "pronto-rubocop", "0.4.4"
gem "pronto-haml", "0.4.3"
# Preloading environment
......
......@@ -347,6 +347,10 @@ GEM
rubocop (~> 0.20)
haml (4.0.6)
tilt
haml_lint (0.13.0)
haml (~> 4.0)
rubocop (>= 0.25.0)
sysexits (~> 1.1)
handlebars_assets (0.20.2)
execjs (~> 2.0)
multi_json (~> 1.0)
......@@ -492,6 +496,9 @@ GEM
octokit (~> 3.8.0)
rugged (~> 0.22.0)
thor (~> 0.19.0)
pronto-haml (0.4.3)
haml_lint (~> 0.13.0)
pronto (~> 0.4.0)
pronto-jshint (0.4.2)
jshintrb (~> 0.3.0)
pronto (~> 0.4.0)
......@@ -720,6 +727,7 @@ GEM
activesupport (>= 3.0)
sprockets (>= 2.8, < 4.0)
state_machine (1.2.0)
sysexits (1.2.0)
systemu (2.6.5)
terminal-table (1.5.2)
test_after_commit (0.4.1)
......@@ -811,6 +819,7 @@ DEPENDENCIES
guard-rspec (= 4.6.3)
guard-rubocop (= 1.2.0)
haml (= 4.0.6)
haml_lint (= 0.13.0)
handlebars_assets (= 0.20.2)
http_accept_language (= 2.0.5)
i18n-inflector-rails (= 1.0.7)
......@@ -839,6 +848,7 @@ DEPENDENCIES
open_graph_reader (= 0.6.1)
pg (= 0.18.2)
pronto (= 0.4.2)
pronto-haml (= 0.4.3)
pronto-jshint (= 0.4.2)
pronto-rubocop (= 0.4.4)
pry
......
#!/usr/bin/env ruby
#
# This file was generated by Bundler.
#
# The application 'haml-lint' is installed as part of a gem, and
# this file is here to facilitate running it.
#
require 'pathname'
ENV['BUNDLE_GEMFILE'] ||= File.expand_path("../../Gemfile",
Pathname.new(__FILE__).realpath)
require 'rubygems'
require 'bundler/setup'
load Gem.bin_path('haml_lint', 'haml-lint')
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment