Commit ce0507f9 authored by Jonne Haß's avatar Jonne Haß

move config/ci to script/ci, update rubygems before bundle install

parent a4b9ae4f
......@@ -12,9 +12,9 @@ env:
- DB=postgres BUILD_TYPE=cucumber
- DB=mysql BUILD_TYPE=cucumber
before_install: gem install bundler --pre
before_install: "./script/ci/before_install.sh"
bundler_args: "--without development production heroku"
before_script: "./config/ci/before-travis.sh"
before_script: "./script/ci/before.sh"
script: "bundle exec rake travis"
......
# Ensure known RubyGems version
if [ "$(gem --version)" != "1.8.12" ]; then
echo "RubyGems version is $(gem --version). Changing..."
rvm rubygems 1.8.12
fi
#!/bin/bash
# Install firefox & Xvfb, in preparation for cucumber & jasmine
#echo "Installing Firefox and Xvfb"
#sudo aptitude --quiet=2 --without-recommends --assume-yes install firefox xvfb
#sudo cp config/ci/xvfb /etc/init.d/xvfb
#sudo cp script/ci/xvfb /etc/init.d/xvfb
echo "Start Xvfb"
sh -e /etc/init.d/xvfb start
......
#!/bin/bash
# Ensure known RubyGems version
if [ "$(gem --version)" != "1.8.12" ]; then
echo "RubyGems version is $(gem --version). Changing..."
rvm rubygems 1.8.12
echo "Changed RubyGems version to $(gem --version)."
fi
# Get latest bundler
gem install bundler --pre
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment